Welcome
User Name
Password

Welcome to the Auris Toyota Club.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Auris Toyota Club > Car Parts and Maintenance > Routine and Preventative Maintenance

Reply
 
LinkBack Thread Tools Display Modes
Old 02-24-2014, 11:13 AM   #1
Senior Member
 
qaz741's Avatar
 
Join Date: Apr 2013
Posts: 124
Default

Hi all,

Was wondering if anyone could shed some light on an issue I had/have?

My Mrs was droning home the other day and the engine and VSC light came on with the car in limp mode.. I went out and reset the car by disconnecting the battery and the second time it was successful. Car would only rev to 3.5k slowly. As soon as it passed this it would rev normal. After a couple of flat out rev s it cleared and all is good. Code reader says

B1421 solar sensor n/s

B1424 solar sensor o/s

C1201 engine control system malfunction ABS/VS/TRC

Any ideas?

Sent from my iPhone using Toyota OC

qaz741 is offline   Reply With Quote
Old 04-17-2014, 02:21 AM   #2
zup
Senior Member
 
zup's Avatar
 
Join Date: Nov 2013
Posts: 109
Send a message via ICQ to zup
Default

And I ve checked the EGR before anyone suggests it. It was the cleanest I have ever seen one. Was really surprised..

Sent from my iPhone using Toyota OC
zup is offline   Reply With Quote
Old 04-30-2014, 01:07 AM   #3
Senior Member
 
Aim at's Avatar
 
Join Date: Jun 2013
Posts: 132
Send a message via ICQ to Aim at
Default

Hi mark,

Possibly needs an ecu upgrade (software rewrite) and/or modified egr valve. Both can be done by a Toyota dealer.

Either that or your inlet manifold is carboned up even though the egr valve is clean. This would be the abs/vs/trc code. The solar sensors are nothing to worry about and not related.

Hope this helps
Aim at is offline   Reply With Quote
Old 05-24-2014, 01:24 AM   #4
Senior Member
 
Kaeltas's Avatar
 
Join Date: Mar 2013
Posts: 139
Send a message via ICQ to Kaeltas
Default

Thanks for your help, to be honest the manifold looks brand new. Noticeably cleaner than the rest of the engine. Possible it s been done? That would explain. Why the EGR is so clean?!

Sent from my iPhone using Toyota OC
Kaeltas is offline   Reply With Quote
Old 06-05-2014, 06:22 AM   #5
Senior Member
 
Gumboldt's Avatar
 
Join Date: Feb 2013
Location: Memphis, Tennessee
Posts: 108
Send a message via ICQ to Gumboldt
Default

Yeah it possibly is new. I d check to see if it s got the latest ecu software on it. Since you cleared the codes, have the lights come back on?
Gumboldt is offline   Reply With Quote
Old 07-05-2014, 01:43 AM   #6
Senior Member
 
Lennoks's Avatar
 
Join Date: Apr 2013
Posts: 151
Send a message via ICQ to Lennoks
Default

With reference EGR issues Toyota have recently added the EGR cooler assembly on the back of the block as a part that can cause P0400 and/or hesitation, surging and lack of power, the official fix is a kit of around 20 parts removing the EGR cooler and replacing it with a kit from a 2009> engine.

This is in addition to the previously known modified EGR, Intake manifold and ECU reprogramme and is covered with the 7 year/111946mile extension already in place which is a good thing as the job is a biggie ranging from 5-10 hours to complete depending on model and previous modification level
__________________
The rose speaks of love silently, in a language known only to the heart.
Lennoks is offline   Reply With Quote
Old 07-09-2014, 08:11 AM   #7
Senior Member
 
E-katerina's Avatar
 
Join Date: Jan 2014
Posts: 132
Send a message via ICQ to E-katerina
Default

Thanks guys, last night I drove from the house and the car would not rev in gear. Very slight incline and couldn t make it in second gear. I put it in 1st and just revved until it hit the red line. As soon as it passed 3k it revved normally again. After that it s fine. No engine light this time....

My car is 58 plate so prob won t get it done under Toyota warranty? But I ve just bought the car so maybe the dealer warranty will cover it? Could you explain what gets changed as I can look myself. It does all look pretty new.
E-katerina is offline   Reply With Quote
Old 08-08-2014, 10:47 AM   #8
Senior Member
 
LuckyScrat's Avatar
 
Join Date: Jan 2014
Posts: 135
Send a message via ICQ to LuckyScrat
Default

Quote:
Yeah it possibly is new. I d check to see if it s got the latest ecu software on it. Since you cleared the codes, have the lights come back on?
i never cleared the codes incase I wanted to take it to the dealer and get repaired.
LuckyScrat is offline   Reply With Quote
Old 08-11-2014, 12:01 PM   #9
Senior Member
 
Dwight's Avatar
 
Join Date: Apr 2013
Posts: 134
Send a message via ICQ to Dwight
Default

While I m here, is there anyway I can just blank off the EGR? Will it cause any lights to come on?

Sent from my iPhone using Toyota OC
Dwight is offline   Reply With Quote
Old 10-17-2014, 11:23 AM   #10
Senior Member
 
davron81's Avatar
 
Join Date: Oct 2013
Location: Boston, Massachusetts
Posts: 117
Send a message via ICQ to davron81
Default

Does anyone else s car idle at 1k when the heater is on?

Sent from my iPhone using Toyota OC
__________________
Illusion is the first of all pleasures.
davron81 is offline   Reply With Quote
Reply
Thread Tools
Display Modes



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.